summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-11 22:40:27 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-11 22:40:27 +0200
commitce6223e68e339f6917c636a194df3dfa95991e74 (patch)
treea07a41111771495899e617cabe018f15e1bbfb92 /gnu
parente4015e570cdeeafdcab766aac02ca0e2340ffe41 (diff)
downloadpatches-ce6223e68e339f6917c636a194df3dfa95991e74.tar
patches-ce6223e68e339f6917c636a194df3dfa95991e74.tar.gz
gnu: shadow: Fix cross-compilation.
* gnu/packages/admin.scm (shadow)[arguments] <set-nscd-file-name>: Refer to "cross-libc" when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 22b19a77ec..319a34ae8b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -306,7 +306,7 @@ hostname.")
"0hdpai78n63l3v3fgr3kkiqzhd0awrpfnnzz4mf7lmxdh61qb37w"))))
(build-system gnu-build-system)
(arguments
- '(;; Assume System V `setpgrp (void)', which is the default on GNU
+ `(;; Assume System V `setpgrp (void)', which is the default on GNU
;; variants (`AC_FUNC_SETPGRP' is not cross-compilation capable.)
#:configure-flags
'("--with-libpam" "ac_cv_func_setpgrp_void=yes")
@@ -316,7 +316,10 @@ hostname.")
(add-before 'build 'set-nscd-file-name
(lambda* (#:key inputs #:allow-other-keys)
;; Use the right file name for nscd.
- (let ((libc (assoc-ref inputs "libc")))
+ (let ((libc (assoc-ref inputs
+ ,(if (%current-target-system)
+ "cross-libc"
+ "libc"))))
(substitute* "lib/nscd.c"
(("/usr/sbin/nscd")
(string-append libc "/sbin/nscd"))))))