summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-10 02:13:05 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 00:04:35 +0200
commitb84ef9e2246024ca0fbec34d0fb0cc39901f674f (patch)
treece7f9b2b1fef7788ec6e37bf8395552c0a2d483d /gnu
parentcf47e34e62ef7547f3596cb652eef2fef7b7a1d2 (diff)
downloadpatches-b84ef9e2246024ca0fbec34d0fb0cc39901f674f.tar
patches-b84ef9e2246024ca0fbec34d0fb0cc39901f674f.tar.gz
gnu: Add python-tqdm.
* gnu/packages/python.scm (python-tqdm, python2-tqdm): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 755fd59294..98fa998042 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16352,3 +16352,32 @@ ignoring formatting changes.")
(define-public python2-nose-timer
(package-with-python2 python-nose-timer))
+
+(define-public python-tqdm
+ (package
+ (name "python-tqdm")
+ (version "4.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tqdm" version))
+ (sha256
+ (base32
+ "0lwrmby8qz23gvqwkpivfrv4q8nfh90cz9ml6slwvwmcxxsdrhbf"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-nose" ,python-nose)
+ ("python-nose-timer" ,python-nose-timer)
+ ("python-coverage" ,python-coverage)
+ ("python-virtualenv" ,python-virtualenv)))
+ (home-page "https://github.com/tqdm/tqdm")
+ (synopsis "Fast, extensible progress meter")
+ (description
+ "Make loops show a progress bar on the console by just wrapping any
+iterable with @code{|tqdm(iterable)|}. Offers many options to define
+design and layout.")
+ (license (list license:mpl2.0 license:expat))))
+
+(define-public python2-tqdm
+ (package-with-python2 python-tqdm))