summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-06 11:56:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit6c04acaa6eb4f3729b116ee34c9f0ede62c12d2f (patch)
tree65ff1f77e2e678c560bef91a74d4982371248656 /gnu
parent1f8a951bf42d10615da66b03b43fa74f1e78d67d (diff)
downloadpatches-6c04acaa6eb4f3729b116ee34c9f0ede62c12d2f.tar
patches-6c04acaa6eb4f3729b116ee34c9f0ede62c12d2f.tar.gz
gnu: Add emacs-skewer-mode.
* gnu/packages/emacs.scm (emacs-skewer-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a251253bfa..d8aa86838c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1459,6 +1459,32 @@ as horizontal rules.")
serve files and directory listings.")
(license license:unlicense)))
+(define-public emacs-skewer-mode
+ (package
+ (name "emacs-skewer-mode")
+ (version "1.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/skeeto/skewer-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07jpz374j0j964szy3zznrkyja2kpdl3xa87wh7349mzxivqxdx0"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-simple-httpd" ,emacs-simple-httpd)
+ ("emacs-js2-mode" ,emacs-js2-mode)))
+ (home-page "https://github.com/skeeto/skewer-mode")
+ (synopsis "Live web development in Emacs")
+ (description
+ "Skewer-mode provides live interaction with JavaScript, CSS, and HTML in
+a web browser. Expressions are sent on-the-fly from an editing buffer to be
+evaluated in the browser, just like Emacs does with an inferior Lisp process
+in Lisp modes.")
+ (license license:unlicense)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")