summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-09-23 05:10:26 +0300
committerAlex Kost <alezost@gmail.com>2017-09-28 18:43:22 +0300
commit69b498a162e9c1fca459bf0737343619e6c7de96 (patch)
tree7b262fe7ece6661708bcb5f941a276c00f3f201a /gnu
parent41342e89ff9a78e48d347c36d830bcfb17f62456 (diff)
downloadpatches-69b498a162e9c1fca459bf0737343619e6c7de96.tar
patches-69b498a162e9c1fca459bf0737343619e6c7de96.tar.gz
gnu: Add emacs-sr-speedbar.
* gnu/packages/emacs.scm (emacs-sr-speedbar): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a6530e924d..ebe099c689 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2121,6 +2121,29 @@ read from small to large monitors by using colors, a prefix feature, and smart
truncation.")
(license license:gpl2+)))
+(define-public emacs-sr-speedbar
+ (package
+ (name "emacs-sr-speedbar")
+ (version "20140914.2339")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/emacsorphanage/sr-speedbar/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15xwwc6kgvmk4wdhx1j8w6m6ivxvc94028ppgdpa2m51a8c9vjm9"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/SrSpeedbar")
+ (synopsis "Same frame Emacs @code{speedbar}")
+ (description
+ "This Emacs package allows you to show @code{M-x speedbar} in the
+same frame (in an extra window). You can customize the initial width of
+the speedbar window.")
+ (license license:gpl3+)))
+
(define-public emacs-shell-switcher
(package
(name "emacs-shell-switcher")