summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:34:27 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:08 +0200
commit6134aeb9ab631744f397ed2fc28f927563865291 (patch)
tree8c64c76469fa4ce959c3d3bc0b0050dedf842da9 /gnu
parent3dabefeef4aab9a0c0dc69e30bbbdd0e2ff15059 (diff)
downloadpatches-6134aeb9ab631744f397ed2fc28f927563865291.tar
patches-6134aeb9ab631744f397ed2fc28f927563865291.tar.gz
gnu: Add ocaml-easy-format.
* gnu/packages/ocaml.scm (ocaml-easy-format): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b4b4f2333b..35a5a10e4e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3253,6 +3253,29 @@ JSON.")
(description "OCaml-uri is a library for parsing URI/URL in the RFC3986 format.")
(license license:isc)))
+(define-public ocaml-easy-format
+ (package
+ (name "ocaml-easy-format")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mjambon/easy-format/"
+ "archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zcz682y9figa84k7lgdjcab5qbzk3yy14ygfqp2dhhrvjygm252"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/mjambon/easy-format")
+ (synopsis "Interface to the Format module")
+ (description "Easy-format is a high-level and functional interface to the
+Format module of the OCaml standard library.")
+ (license license:bsd-3)))
+
(define-public coq-flocq
(package
(name "coq-flocq")