summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-05 15:41:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit3bcb304ea8b0d1f9e134810137e6496f99799c4e (patch)
treee9994a7d17b27428e60bf69711cadd51fe9acb10 /gnu
parentdbe38a3a589508986cf91dfac9c641f8da41bf93 (diff)
downloadpatches-3bcb304ea8b0d1f9e134810137e6496f99799c4e.tar
patches-3bcb304ea8b0d1f9e134810137e6496f99799c4e.tar.gz
gnu: Add emacs-shell-switcher.
* gnu/packages/emacs.scm (emacs-shell-switcher): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a1fb88542c..27c50f7f0e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1574,6 +1574,26 @@ read from small to large monitors by using colors, a prefix feature, and smart
truncation.")
(license license:gpl2+)))
+(define-public emacs-shell-switcher
+ (package
+ (name "emacs-shell-switcher")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/DamienCassou/shell-switcher"
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c23mfkdqz2g9rixd9smm323vzlvhzz3ng34ambcqjfq309qb2nz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/DamienCassou/shell-switcher")
+ (synopsis "Provide fast switching between shell buffers")
+ (description
+ "This package provides commands to quickly switch between shell buffers.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")