summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-06 11:56:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit1f8a951bf42d10615da66b03b43fa74f1e78d67d (patch)
tree95de6207ea15acc1438888a5296ceab3b9218700 /gnu
parenta46e3c0dc606b0f8e04fcf224113eb3de4d865b7 (diff)
downloadpatches-1f8a951bf42d10615da66b03b43fa74f1e78d67d.tar
patches-1f8a951bf42d10615da66b03b43fa74f1e78d67d.tar.gz
gnu: Add emacs-simple-httpd.
* gnu/packages/emacs.scm (emacs-simple-httpd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 50f077fa23..a251253bfa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1438,6 +1438,27 @@ subconsciously blend out the parentheses.")
as horizontal rules.")
(license license:gpl3+)))
+(define-public emacs-simple-httpd
+ (package
+ (name "emacs-simple-httpd")
+ (version "1.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/skeeto/emacs-web-server/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01r7h3imnj4qx1m53a2wjafvbylcyz5f9r2rg2cs7ky3chlg220r"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/skeeto/emacs-http-server")
+ (synopsis "HTTP server in pure Emacs Lisp")
+ (description
+ "This package provides a simple HTTP server written in Emacs Lisp to
+serve files and directory listings.")
+ (license license:unlicense)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")