summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-12 20:29:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit0c5d837c8238b850cbd1d9a97dfbdd2b1a2cdbae (patch)
treebb01101a4332002ae2bd2f416976bba0081dbfd3 /gnu
parent1c32830b7d3496c2729449ef0d0f9f72d543b308 (diff)
downloadpatches-0c5d837c8238b850cbd1d9a97dfbdd2b1a2cdbae.tar
patches-0c5d837c8238b850cbd1d9a97dfbdd2b1a2cdbae.tar.gz
gnu: Add emacs-espuds.
* gnu/packages/emacs.scm (emacs-espuds): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 95c8d9b756..fb84d90c1e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1305,6 +1305,30 @@ syntax. Most commonly Emacs Lisp Mock is used in conjunction with Emacs Lisp
Expectations, but it can be used in other contexts.")
(license license:gpl3+)))
+(define-public emacs-espuds
+ (package
+ (name "emacs-espuds")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ecukes/espuds/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xv551376pbmh735a3zjwc9z4qdx6ngj1vpq3xqjpn0a1rwjyn4k"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "http://github.com/ecukes/espuds")
+ (synopsis "Common step definitions for Ecukes")
+ (description "Espuds is a collection of the most commonly used step
+definitions for testing with the Ecukes framework.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")