summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-06 09:12:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit07046e5f44577f2a1c00627f7af2a5d8cfb4e2b1 (patch)
tree8e6ab8470d00988e1e50d7b4bcf138d6fda4b199 /gnu
parent7b9769b04d66c3121c5295676f4d5ae686c96936 (diff)
downloadpatches-07046e5f44577f2a1c00627f7af2a5d8cfb4e2b1.tar
patches-07046e5f44577f2a1c00627f7af2a5d8cfb4e2b1.tar.gz
gnu: Add emacs-paren-face.
* gnu/packages/emacs.scm (emacs-paren-face): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d2e306b248..99fa32cbd0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1392,6 +1392,31 @@ column by drawing a thin line down the length of the editing window.")
IRC bouncer with ERC.")
(license license:expat)))
+(define-public emacs-paren-face
+ (package
+ (name "emacs-paren-face")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tarsius/paren-face/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y4qrhxa9332vsvr999jg7qj1ymnfgwpf591yi4a4jgg90pm7qnn"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/tarsius/paren-face")
+ (synopsis "Face for parentheses in lisp modes")
+ (description
+ "This library defines a face named @code{parenthesis} used just for
+parentheses. The intended purpose of this face is to make parentheses less
+visible in Lisp code by dimming them. Lispers probably don't need to be
+constantly made aware of the existence of the parentheses. Dimming them might
+be even more useful for people new to lisp who have not yet learned to
+subconsciously blend out the parentheses.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")