summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-07-14 19:23:37 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-14 19:23:37 +1000
commit06e372360eed08a1cbbb2081a591fbfa4785a2f2 (patch)
tree93396cbc45af6c4bcf6c61aed505f607d2afd08e /gnu
parentd6e63cf31cc113e310cd0e5dda9ac4f73a5caeae (diff)
downloadpatches-06e372360eed08a1cbbb2081a591fbfa4785a2f2.tar
patches-06e372360eed08a1cbbb2081a591fbfa4785a2f2.tar.gz
gnu: bowtie: Use 'modify-phases'.
* gnu/packages/bioinformatics.scm (bowtie)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a9f6259897..b5ee9cc125 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1225,16 +1225,14 @@ errors at the end of reads.")
"WITH_TBB=1"
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
- (alist-delete
- 'configure
- (alist-replace
- 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (system* "perl"
- "scripts/test/simple_tests.pl"
- "--bowtie2=./bowtie2"
- "--bowtie2-build=./bowtie2-build"))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "perl"
+ "scripts/test/simple_tests.pl"
+ "--bowtie2=./bowtie2"
+ "--bowtie2-build=./bowtie2-build")))))))
(home-page "http://bowtie-bio.sourceforge.net/bowtie2/index.shtml")
(synopsis "Fast and sensitive nucleotide sequence read aligner")
(description