summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-25 14:38:50 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-25 15:29:29 -0400
commit4fdab1737186afefa3a80c2a3ed1fdaa48c9c57a (patch)
treef79f93b2a98d08e9fbbb4ff2daa6f88e58cd161b /gnu
parente9f468dfcdc91915f6eaeac335e54d70d9cf5117 (diff)
downloadpatches-4fdab1737186afefa3a80c2a3ed1fdaa48c9c57a.tar
patches-4fdab1737186afefa3a80c2a3ed1fdaa48c9c57a.tar.gz
gnu: python2-urwid: Actually build urwid for Python 2.
* gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 89c2de63bd..03f8134115 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5871,7 +5871,11 @@ features useful for text console applications.")
(inherit python2-urwid)
(arguments
(append
- '(#:phases
+ `(;; Explicitly using Python 2 is necessary due the argument list being
+ ;; built from only the 'delete-test_vterm.py' phase and python-urwid's
+ ;; package arguments, which by default assumes the use of Python 3.
+ #:python ,python-2
+ #:phases
(modify-phases %standard-phases
;; Disable the vterm tests because of non-deterministic failures
;; with Python 2. See https://github.com/urwid/urwid/issues/230.