summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 20:55:20 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:29 +0200
commitd02addd52dbf09961c19eec85d10c93b2cfb6ef8 (patch)
treee24bbe091025d33c3624d35927d3e76f676af06d /gnu
parentef0f84502cc1d32184252529eda8e0c873b4d10c (diff)
downloadpatches-d02addd52dbf09961c19eec85d10c93b2cfb6ef8.tar
patches-d02addd52dbf09961c19eec85d10c93b2cfb6ef8.tar.gz
gnu: Add kdesignerplugin.
* gnu/packages/kde-frameworks.scm (kdesignerplugin): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0a049db7ef..98c453b85c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1818,3 +1818,40 @@ performs a number of small tasks. Some of these tasks are built in, others are
started on demand.")
;; dual licensed
(license (list license:lgpl2.0+ license:lgpl2.1+))))
+
+(define-public kdesignerplugin
+ (package
+ (name "kdesignerplugin")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i0s8pwwhwh5hyyvkv0cnj0yyv0g5bnm5xw18knv2yagiy4bvb2j"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdoctools" ,kdoctools)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Integrating KDE frameworks widgets with Qt Designer")
+ (description "This framework provides plugins for Qt Designer that allow it
+to display the widgets provided by various KDE frameworks, as well as a utility
+(kgendesignerplugin) that can be used to generate other such plugins from
+ini-style description files.")
+ (license license:lgpl2.1+)))