summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
commit426adbe82731b8b4968cad8d474545d3e8b55c65 (patch)
tree5fbc7f62c5bfa2e3a97c01c7974d119cf6400824 /gnu
parent1ddbd9fd71502c9332ca84a74734121c407a5708 (diff)
downloadpatches-426adbe82731b8b4968cad8d474545d3e8b55c65.tar
patches-426adbe82731b8b4968cad8d474545d3e8b55c65.tar.gz
gnu: glib: Add "bin" output.
Fixes <http://bugs.gnu.org/17853>. * gnu/packages/glib.scm (glib)[outputs]: Add "bin". (gobject-introspection)[native-inputs]: New field. * gnu/packages/avahi.scm (avahi)[native-inputs]: Add glib:bin. * gnu/packages/gnome.scm (brasero, libgnome-keyring, evince, gsettings-desktop-schemas, libnotify, gtkglext): Likewise. * gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base, gst-plugins-base-0.10): Likewise. * gnu/packages/gtk.scm (atk, pango, gdk-pixbuf, gtk+-2, gtk+): Likewise. * gnu/packages/linux.scm (udev): Likewise. * gnu/packages/pdf.scm (poppler): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/avahi.scm3
-rw-r--r--gnu/packages/glib.scm7
-rw-r--r--gnu/packages/gnome.scm13
-rw-r--r--gnu/packages/gstreamer.scm5
-rw-r--r--gnu/packages/gtk.scm5
-rw-r--r--gnu/packages/linux.scm1
-rw-r--r--gnu/packages/pdf.scm3
7 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index bc70878d46..d3a92844c2 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +60,7 @@
("libdaemon" ,libdaemon)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(synopsis "Avahi, an mDNS/DNS-SD implementation")
(description
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 77f21f95ce..ce0d3f821d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -119,8 +119,9 @@ shared NFS home directories.")
(search-patch "glib-tests-prlimit.patch")
(search-patch "glib-tests-newnet.patch")))))
(build-system gnu-build-system)
- (outputs '("out" ; everything
- "doc")) ; 20 MiB of GTK-Doc reference
+ (outputs '("out" ; everything
+ "bin" ; glib-mkenums, gtester, etc.; depends on Python
+ "doc")) ; 20 MiB of GTK-Doc reference
(inputs
`(("coreutils" ,coreutils)
("libffi" ,libffi)
@@ -201,6 +202,8 @@ dynamic loading, and an object system.")
("glib" ,glib)
("pkg-config" ,pkg-config)
("python-2" ,python-2)))
+ (native-inputs
+ `(("glib" ,glib "bin")))
(propagated-inputs
`(;; In practice, GIR users will need libffi when using
;; gobject-introspection.
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ee7c7c5ab1..dd407c5eeb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -60,6 +60,7 @@
`(("hicolor-icon-theme" ,hicolor-icon-theme)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)
@@ -73,9 +74,6 @@
("libnotify" ,libnotify)
("libsm" ,libsm)
("libxml2" ,libxml2)))
- (native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/brasero/")
(synopsis "CD/DVD burning tool for Gnome")
(description "Brasero is an application to burn CD/DVD for the Gnome
@@ -173,6 +171,7 @@ and keep up to date translations of documentation.")
("dbus" ,dbus)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("intltool" ,intltool)))
(propagated-inputs
;; Referred to in .h files and .pc.
@@ -239,6 +238,7 @@ and keep up to date translations of documentation.")
("dogtail" ,python2-dogtail)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page
"http://www.gnome.org/projects/evince/")
@@ -268,6 +268,7 @@ on the GNOME Desktop with a single simple application.")
`(("glib" ,glib)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)))
(home-page "https://launchpad.net/gsettings-desktop-schemas")
(synopsis
@@ -402,7 +403,8 @@ database is translated at Transifex.")
("gtk+" ,gtk+)
("libpng" ,libpng)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")))
(home-page "https://developer-next.gnome.org/libnotify/")
(synopsis
"GNOME desktop notification library")
@@ -465,7 +467,8 @@ the API")
("mesa" ,mesa)
("libx11" ,libx11)
("libxt" ,libxt)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")))
(propagated-inputs `(("pangox-compat" ,pangox-compat)))
(home-page "https://projects.gnome.org/gtkglext")
(synopsis "OpenGL extension to GTK+.")
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index c68d756d1e..6f6494d4d4 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -51,6 +51,7 @@
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
+ ("glib" ,glib "bin")
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
@@ -112,6 +113,7 @@ This package provides the core library and elements.")
("gstreamer" ,gstreamer)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("python-wrapper" ,python-wrapper)))
(arguments
`(#:tests? #f))
@@ -154,4 +156,5 @@ This package provides an essential exemplary set of elements.")
("gstreamer" ,gstreamer-0.10)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python-2)))))
+ ("glib" ,glib "bin")
+ ("python" ,python-2)))))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2823ef008f..36fea70838 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -54,6 +54,7 @@
(inputs `(("glib" ,glib)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME accessibility toolkit")
(description
@@ -158,6 +159,7 @@ affine transformation (scale, rotation, shear, etc.)")
`(("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME text and font handling library")
(description
@@ -267,6 +269,7 @@ printing and other features typical of a source code editor.")
("libtiff" ,libtiff)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection", gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME image loading and manipulation library")
(description
@@ -353,6 +356,7 @@ is part of the GNOME accessibility project.")
("pango" ,pango)))
(native-inputs
`(("perl" ,perl)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
@@ -395,6 +399,7 @@ application suites.")
`(("libxml2" ,libxml2)))
(native-inputs
`(("perl" ,perl)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 841ec581d9..d6633631b8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1254,6 +1254,7 @@ from the module-init-tools project.")
(native-inputs
`(("pkg-config" ,pkg-config)
("gperf" ,gperf)
+ ("glib" ,glib "bin") ; glib-genmarshal, etc.
("perl" ,perl) ; for the tests
("python" ,python-2))) ; ditto
(inputs
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index c8fa4593fb..1f27723f13 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -66,7 +66,8 @@
(package-inputs cairo)))))
("glib" ,glib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin"))) ; glib-mkenums, etc.
(arguments
`(#:tests? #f ; no test data provided with the tarball
#:configure-flags