summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-13 20:59:34 +0200
committerDavid Craven <david@craven.ch>2016-09-13 21:01:27 +0200
commit035d359338b7f58f90f69d5471e216f9d13fdaee (patch)
tree6790c816f42c85fa1f9328bc315eb1f1a828cd38 /gnu
parentcff0adec0c621f77238f533a2cf544f9bc33c659 (diff)
downloadpatches-035d359338b7f58f90f69d5471e216f9d13fdaee.tar
patches-035d359338b7f58f90f69d5471e216f9d13fdaee.tar.gz
gnu: module-init-tools: Move to (gnu packages linux).
* gnu/packages/linux.scm (module-init-tools): Move.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm64
1 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 455947d1e4..981ac60dd5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -167,38 +167,6 @@
(license license:gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
-(define-public module-init-tools
- (package
- (name "module-init-tools")
- (version "3.16")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kernel.org/linux/utils/kernel/module-init-tools/"
- "module-init-tools-" version ".tar.bz2"))
- (sha256
- (base32
- "0jxnz9ahfic79rp93l5wxcbgh4pkv85mwnjlbv1gz3jawv5cvwp1"))
- (patches (search-patches "module-init-tools-moduledir.patch"))))
- (build-system gnu-build-system)
- (arguments
- ;; FIXME: The upstream tarball lacks man pages, and building them would
- ;; require DocBook & co. We used to use Gentoo's pre-built man pages,
- ;; but they vanished. In the meantime, fake it.
- '(#:phases (alist-cons-before
- 'configure 'fake-docbook
- (lambda _
- (substitute* "Makefile.in"
- (("^DOCBOOKTOMAN.*$")
- "DOCBOOKTOMAN = true\n")))
- %standard-phases)))
- (home-page "http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/")
- (synopsis "Tools for loading and managing Linux kernel modules")
- (description
- "Tools for loading and managing Linux kernel modules, such as `modprobe',
-`insmod', `lsmod', and more.")
- (license license:gpl2+)))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -2940,3 +2908,35 @@ extensible array of mapping functions, currently consisting of two choices:
the default @code{nsswitch} and the experimental @code{umich_ldap}.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
+
+(define-public module-init-tools
+ (package
+ (name "module-init-tools")
+ (version "3.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel.org/linux/utils/kernel/module-init-tools/"
+ "module-init-tools-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0jxnz9ahfic79rp93l5wxcbgh4pkv85mwnjlbv1gz3jawv5cvwp1"))
+ (patches (search-patches "module-init-tools-moduledir.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; FIXME: The upstream tarball lacks man pages, and building them would
+ ;; require DocBook & co. We used to use Gentoo's pre-built man pages,
+ ;; but they vanished. In the meantime, fake it.
+ '(#:phases (alist-cons-before
+ 'configure 'fake-docbook
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^DOCBOOKTOMAN.*$")
+ "DOCBOOKTOMAN = true\n")))
+ %standard-phases)))
+ (home-page "http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/")
+ (synopsis "Tools for loading and managing Linux kernel modules")
+ (description
+ "Tools for loading and managing Linux kernel modules, such as `modprobe',
+`insmod', `lsmod', and more.")
+ (license license:gpl2+)))