summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-29 14:37:38 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-03 13:46:52 +0100
commit69e0e03c36f913f4d6a1e2f4a1f295fff9a44a9a (patch)
tree86623a4d10d798a86a69f66bcecda6bf6e8ade45 /gnu
parentd454640c3835f0d29a4065eac3611ab475d1c190 (diff)
downloadpatches-69e0e03c36f913f4d6a1e2f4a1f295fff9a44a9a.tar
patches-69e0e03c36f913f4d6a1e2f4a1f295fff9a44a9a.tar.gz
gnu: Add python-pybigwig.
* gnu/packages/bioinformatics.scm (python-pybigwig, python2-pybigwig): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c797f5f2d6..8e9f1707a5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1194,6 +1194,47 @@ other types of unwanted sequence from high-throughput sequencing reads.")
files.")
(license license:expat)))
+(define-public python-pybigwig
+ (package
+ (name "python-pybigwig")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyBigWig" version))
+ (sha256
+ (base32
+ "0yrpdxg3y0sny25x4w22lv1k47jzccqjmg7j4bp0hywklvp0hg7d"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled libBigWig sources
+ (delete-file-recursively "libBigWig")))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'link-with-libBigWig
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("libs=\\[") "libs=[\"BigWig\", "))
+ #t)))))
+ (inputs
+ `(("libbigwig" ,libbigwig)
+ ("zlib" ,zlib)
+ ("curl" ,curl)))
+ (home-page "https://github.com/dpryan79/pyBigWig")
+ (synopsis "Access bigWig files in Python using libBigWig")
+ (description
+ "This package provides Python bindings to the libBigWig library for
+accessing bigWig files.")
+ (license license:expat)))
+
+(define-public python2-pybigwig
+ (let ((pybigwig (package-with-python2 python-pybigwig)))
+ (package (inherit pybigwig)
+ (native-inputs
+ `(("python-setuptools" ,python2-setuptools))))))
+
(define-public deeptools
(package
(name "deeptools")