summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-25 14:01:14 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-03 13:46:26 +0100
commit55a9a8c2b91b19b6233eaee6d1a42f8b7be7235f (patch)
treeff407f408499c31f0b17d07a70f22adbd5f75dc2 /gnu
parent937690f90937c19b6708d60342efcd4b81044795 (diff)
downloadpatches-55a9a8c2b91b19b6233eaee6d1a42f8b7be7235f.tar
patches-55a9a8c2b91b19b6233eaee6d1a42f8b7be7235f.tar.gz
gnu: python-pysam, python2-pysam: Move to bioinformatics.scm.
* gnu/packages/python.scm (python-pysam, python2-pysam): Move to... * gnu/packages/bioinformatics.scm (python-pysam, python2-pysam): ...here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm38
-rw-r--r--gnu/packages/python.scm38
2 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5f8ce22a8b..45ab9aa7b3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -838,6 +838,44 @@ well as many of the command line options.")
multiple sequence alignments.")
(license license:expat)))
+(define-public python-pysam
+ (package
+ (name "python-pysam")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/pysam/pysam-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1fb6i6hbpzxaxb62kyyp5alaidwhj40f7c6gwbhr6njzlqd5l459"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; tests are excluded in the manifest
+ #:phases
+ (alist-cons-before
+ 'build 'set-flags
+ (lambda _
+ (setenv "LDFLAGS" "-lncurses")
+ (setenv "CFLAGS" "-D_CURSES_LIB=1"))
+ %standard-phases)))
+ (inputs
+ `(("python-cython" ,python-cython)
+ ("python-setuptools" ,python-setuptools)
+ ("ncurses" ,ncurses)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/pysam-developers/pysam")
+ (synopsis "Python bindings to the SAMtools C API")
+ (description
+ "Pysam is a Python module for reading and manipulating files in the
+SAM/BAM format. Pysam is a lightweight wrapper of the SAMtools C API. It
+also includes an interface for tabix.")
+ (license license:expat)))
+
+(define-public python2-pysam
+ (package-with-python2 python-pysam))
+
(define-public clipper
(package
(name "clipper")
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4f34537df6..131ec6207b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1040,44 +1040,6 @@ get the local timezone information, unless you know the zoneinfo name, and
under several distributions that's hard or impossible to figure out.")
(license cc0)))
-(define-public python-pysam
- (package
- (name "python-pysam")
- (version "0.8.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/p/pysam/pysam-"
- version ".tar.gz"))
- (sha256
- (base32
- "1fb6i6hbpzxaxb62kyyp5alaidwhj40f7c6gwbhr6njzlqd5l459"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ; tests are excluded in the manifest
- #:phases
- (alist-cons-before
- 'build 'set-flags
- (lambda _
- (setenv "LDFLAGS" "-lncurses")
- (setenv "CFLAGS" "-D_CURSES_LIB=1"))
- %standard-phases)))
- (inputs
- `(("python-cython" ,python-cython)
- ("python-setuptools" ,python-setuptools)
- ("ncurses" ,ncurses)
- ("zlib" ,zlib)))
- (home-page "https://github.com/pysam-developers/pysam")
- (synopsis "Python bindings to the SAMtools C API")
- (description
- "Pysam is a Python module for reading and manipulating files in the
-SAM/BAM format. Pysam is a lightweight wrapper of the SAMtools C API. It
-also includes an interface for tabix.")
- (license license:expat)))
-
-(define-public python2-pysam
- (package-with-python2 python-pysam))
-
(define-public python2-pysqlite
(package
(name "python2-pysqlite")