summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-08-01 22:43:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-08-02 12:19:41 +0300
commite8d8b485d0064fec8a8aa51b3ddb612fd722389e (patch)
tree693f7ca82f69cc820695a44633ad7f9dafcbfa06 /gnu
parent7217d337550c9e5d64c4ad0ddfe75599fd47cd56 (diff)
downloadpatches-e8d8b485d0064fec8a8aa51b3ddb612fd722389e.tar
patches-e8d8b485d0064fec8a8aa51b3ddb612fd722389e.tar.gz
gnu: minetest: Don't use unstable tarball.
* gnu/packages/games.scm (minetest)[source]: Download from git repository.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0174d5bfa2..c96ccede1e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1612,14 +1612,14 @@ match, cannon keep, and grave-itation pit.")
(name "minetest")
(version "0.4.17.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/minetest/minetest/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest/minetest")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ngb3h6hw0zbsr6isjpyp4fach0g4nbn6bxxv9g354plac6d89fd"))))
+ "19sfblgh9mchkgw32n7gdvm7a8a9jxsl9cdlgmxn9bk9m939a2sg"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags