summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-30 21:17:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-01 13:32:10 +0200
commit9ec5496525c6c20a174b487a69ecd555af56b924 (patch)
treed90ffbb1a1c7caa4275c017589158b87731221cb /gnu
parentbf5e7c82323abfdd0795863b3ebca5b99f0b2360 (diff)
downloadpatches-9ec5496525c6c20a174b487a69ecd555af56b924.tar
patches-9ec5496525c6c20a174b487a69ecd555af56b924.tar.gz
gnu: upower: Update to 0.99.8.
* gnu/packages/gnome.scm (upower): Update to 0.99.8. [source](uri): Change to new download location*. [arguments]: Remove #:phases. * https://lists.freedesktop.org/archives/devkit-devel/2018-June/001829.html
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b1a0ccdc12..3d3d77bf26 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2928,14 +2928,15 @@ faster results and to avoid unnecessary server load.")
(define-public upower
(package
(name "upower")
- (version "0.99.4")
+ (version "0.99.8")
(source (origin
(method url-fetch)
- (uri (string-append "https://upower.freedesktop.org/releases/"
- name "-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.freedesktop.org/upower/upower/"
+ "uploads/9125ab7ee96fdc4ecc68cfefb50c1cab/"
+ "upower-" version ".tar.xz"))
(sha256
(base32
- "1c1ph1j1fnrf3vipxb7ncmdfc36dpvcvpsv8n8lmal7grjk2b8ww"))
+ "00lzr0vyxz5lvmgya48gdb2cdgmfdim4b34jlfdyqakk1i9sl8xv"))
(patches (search-patches "upower-builddir.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -2946,17 +2947,7 @@ faster results and to avoid unnecessary server load.")
#:configure-flags (list "--localstatedir=/var"
(string-append "--with-udevrulesdir="
(assoc-ref %outputs "out")
- "/lib/udev/rules.d"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/true
- (lambda _
- (substitute* "configure"
- (("/bin/true") (which "true")))))
- (add-before 'configure 'patch-integration-test
- (lambda _
- (substitute* "src/linux/integration-test"
- (("/usr/bin/python3") (which "python3"))))))))
+ "/lib/udev/rules.d"))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)