summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-26 07:49:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-26 07:49:50 +0200
commit3c5698046a4b4c8934866e0195e899f73163020d (patch)
treec646996d09da3de12cba9ec50acebb64d66d2cc0 /gnu
parentff4dc16eac6c15dfa2bc0ef92ea3b6b9f29d0680 (diff)
downloadpatches-3c5698046a4b4c8934866e0195e899f73163020d.tar
patches-3c5698046a4b4c8934866e0195e899f73163020d.tar.gz
gnu: libtorrent-rasterbar: Update to 1.1.2.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.1.2. [source]: Use patch. * gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bittorrent.scm10
-rw-r--r--gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch27
3 files changed, 35 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ba908cd4aa..782bf74791 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -712,6 +712,7 @@ dist_patch_DATA = \
%D%/packages/patches/libtiff-invalid-read.patch \
%D%/packages/patches/libtiff-null-dereference.patch \
%D%/packages/patches/libtiff-tiffcp-underflow.patch \
+ %D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
%D%/packages/patches/libtool-skip-tests2.patch \
%D%/packages/patches/libunwind-CVE-2015-3239.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 635b94f4a0..a0474002b7 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -31,6 +31,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module ((guix licenses) #:prefix l:)
+ #:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -379,16 +380,19 @@ and will take advantage of multiple processor cores where possible.")
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "1.0.10")
+ (version "1.1.2")
(source (origin
(method url-fetch)
(uri
(string-append
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
- "1_0_10" "/libtorrent-rasterbar-" version ".tar.gz"))
+ (string-join (string-split version #\.) "_")
+ "/libtorrent-rasterbar-" version ".tar.gz"))
+ (patches
+ (search-patches "libtorrent-rasterbar-boost-compat.patch"))
(sha256
(base32
- "0gjcr892hzmcngvpw5bycjci4dk49v763lsnpvbwsjmim2ncwrd8"))))
+ "16im9qsmfrmmkhfjpij9739nqpn4s6wgc9cikdxbcyshfhimzra5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch b/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch
new file mode 100644
index 0000000000..85bea76efe
--- /dev/null
+++ b/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch
@@ -0,0 +1,27 @@
+Fix compatibility with Boost 1.63.
+
+Patch copied from upstream source repository:
+
+https://github.com/arvidn/libtorrent/commit/6d2d736cecce0af274dd651dd1f562716b625d92
+
+From 6d2d736cecce0af274dd651dd1f562716b625d92 Mon Sep 17 00:00:00 2001
+From: arvidn <arvid@cs.umu.se>
+Date: Sun, 12 Mar 2017 13:03:26 -0400
+Subject: [PATCH] fix test_ssl.cpp build with newer versions of boost
+
+---
+ test/test_ssl.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
+index 01c5bc7..2903332 100644
+--- a/test/test_ssl.cpp
++++ b/test/test_ssl.cpp
+@@ -51,7 +51,6 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include <boost/asio/connect.hpp>
+
+ #ifdef TORRENT_USE_OPENSSL
+-#include <boost/asio/ssl/error.hpp> // for asio::error::get_ssl_category()
+ #include <boost/asio/ssl.hpp>
+
+ #include "libtorrent/aux_/disable_warnings_pop.hpp"