summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 20:48:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit24857542bddb9e0dabe11fd099b81a8b3060fe74 (patch)
treefe42a984eb7e1ba9db979d4534c067ee43164af8 /gnu
parent5e51bcf7b38511d943f4d24621be5817144061cd (diff)
downloadpatches-24857542bddb9e0dabe11fd099b81a8b3060fe74.tar
patches-24857542bddb9e0dabe11fd099b81a8b3060fe74.tar.gz
gnu: ghc-generic-deriving: Update to 1.11.1.
* gnu/packages/haskell.scm (ghc-generic-deriving): Update to 1.11.1. [native-inputs]: Add ghc-hspec and hspec-discover.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4061d5f201..9f10818f7b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2639,7 +2639,7 @@ exceptions.")
(define-public ghc-generic-deriving
(package
(name "ghc-generic-deriving")
- (version "1.8.0")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
@@ -2649,8 +2649,11 @@ exceptions.")
".tar.gz"))
(sha256
(base32
- "1kc6lhdanls6kgpk8xv5xi14lz1sngcd8xn930hkf7ilq4kxkcr6"))))
+ "1sdh5hpcwvh3b6zvgfk3pr3hla8p88l82njnih880c0gk5zl53dk"))))
(build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
(home-page "https://hackage.haskell.org/package/generic-deriving")
(synopsis "Generalise the deriving mechanism to arbitrary classes")
(description "This package provides functionality for generalising the