summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 22:59:24 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:54 -0500
commitc1637311b6331588734791a87376023338b6a4a3 (patch)
tree227ec8c1d95f4a6337941bf6440ccdd78a63d9b3 /gnu
parent74be1cb7b4780d32485848d7e121d05e0aaa670e (diff)
downloadpatches-c1637311b6331588734791a87376023338b6a4a3.tar
patches-c1637311b6331588734791a87376023338b6a4a3.tar.gz
gnu: ngless: Update to 1.0.1.
* gnu/packages/bioinformatics.scm (ngless): Update to 1.0.1. [arguments]: Add a 'create-Versions.hs' phase that patches the Makefile and invokes 'make' to generate a required file. [inputs]: Remove 'ghc-chart', 'ghc-chart-cairo', and 'ghc-conduit-combinators'; add 'ghc-diagrams-core', 'ghc-diagrams-lib', 'ghc-diagrams-svg', and 'ghc-tar-conduit'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 24 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 07c70fb82c..511146bb6e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13890,7 +13890,7 @@ datasets.")
(define-public ngless
(package
(name "ngless")
- (version "0.9.1")
+ (version "1.0.1")
(source
(origin
(method git-fetch)
@@ -13900,7 +13900,7 @@ datasets.")
(file-name (git-file-name name version))
(sha256
(base32
- "0mc2gi7h4lx74zylvyp76mvc0w6706j858ii9vlgzqsw6acpr117"))))
+ "06ygv8q2zjqsnrid1302yrlhhvb8ik48nq6n0higk3i1mdc8r0dg"))))
(build-system haskell-build-system)
(arguments
`(#:haddock? #f ; The haddock phase fails with: NGLess/CmdArgs.hs:20:1:
@@ -13908,7 +13908,24 @@ datasets.")
; import Options.Applicative
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'create-cabal-file
+ (add-after 'unpack 'create-Versions.hs
+ (lambda _
+ (substitute* "Makefile"
+ (("BWA_VERSION = .*")
+ (string-append "BWA_VERSION = "
+ ,(package-version bwa) "\n"))
+ (("SAM_VERSION = .*")
+ (string-append "SAM_VERSION = "
+ ,(package-version samtools) "\n"))
+ (("PRODIGAL_VERSION = .*")
+ (string-append "PRODIGAL_VERSION = "
+ ,(package-version prodigal) "\n"))
+ (("MINIMAP2_VERSION = .*")
+ (string-append "MINIMAP2_VERSION = "
+ ,(package-version minimap2) "\n")))
+ (invoke "make" "NGLess/Dependencies/Versions.hs")
+ #t))
+ (add-after 'create-Versions.hs 'create-cabal-file
(lambda _ (invoke "hpack") #t))
;; These tools are expected to be installed alongside ngless.
(add-after 'install 'link-tools
@@ -13937,15 +13954,15 @@ datasets.")
("ghc-async" ,ghc-async)
("ghc-atomic-write" ,ghc-atomic-write)
("ghc-bytestring-lexing" ,ghc-bytestring-lexing)
- ("ghc-chart" ,ghc-chart)
- ("ghc-chart-cairo" ,ghc-chart-cairo)
("ghc-conduit" ,ghc-conduit)
("ghc-conduit-algorithms" ,ghc-conduit-algorithms)
- ("ghc-conduit-combinators" ,ghc-conduit-combinators)
("ghc-conduit-extra" ,ghc-conduit-extra)
("ghc-configurator" ,ghc-configurator)
("ghc-convertible" ,ghc-convertible)
("ghc-data-default" ,ghc-data-default)
+ ("ghc-diagrams-core" ,ghc-diagrams-core)
+ ("ghc-diagrams-lib" ,ghc-diagrams-lib)
+ ("ghc-diagrams-svg" ,ghc-diagrams-svg)
("ghc-double-conversion" ,ghc-double-conversion)
("ghc-edit-distance" ,ghc-edit-distance)
("ghc-either" ,ghc-either)
@@ -13966,6 +13983,7 @@ datasets.")
("ghc-safeio" ,ghc-safeio)
("ghc-strict" ,ghc-strict)
("ghc-tar" ,ghc-tar)
+ ("ghc-tar-conduit" ,ghc-tar-conduit)
("ghc-unliftio" ,ghc-unliftio)
("ghc-unliftio-core" ,ghc-unliftio-core)
("ghc-vector" ,ghc-vector)