summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-25 15:17:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-25 15:30:07 +0200
commitcd8dce8ac4224d425f13b3c0776884c87ff43562 (patch)
tree7fc7fca8707d573dbc789536db4f408e79d10229 /gnu
parent37da4fbe1562583589eeddb4be8e11bece80fd35 (diff)
downloadpatches-cd8dce8ac4224d425f13b3c0776884c87ff43562.tar
patches-cd8dce8ac4224d425f13b3c0776884c87ff43562.tar.gz
gnu: gnome-shell: Add gdk-pixbuf+svg to inputs.
Fixes <https://bugs.gnu.org/34124>. * gnu/packages/gnome.scm (gnome-shell)[inputs]: Add gdk-pixbuf+svg. [arguments]: Add the lib directory of gdk-pixbuf+svg to the LD_LIBRARY_PATH wrapper of the gnome-shell executable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5583af576b..e4739ec8fe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5932,7 +5932,8 @@ properties, screen resolution, and other GNOME parameters.")
`("LD_LIBRARY_PATH" ":" prefix
,(map (lambda (pkg)
(string-append (assoc-ref inputs pkg) "/lib"))
- '("gnome-bluetooth" "librsvg" "libgweather"))))
+ '("gdk-pixbuf"
+ "gnome-bluetooth" "librsvg" "libgweather"))))
(for-each
(lambda (prog)
(wrap-program (string-append out "/bin/" prog)
@@ -5969,6 +5970,7 @@ properties, screen resolution, and other GNOME parameters.")
("evolution-data-server" ,evolution-data-server)
("gcr" ,gcr)
("gdm" ,gdm)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("gjs" ,gjs)
("gnome-bluetooth" ,gnome-bluetooth)
("gnome-desktop" ,gnome-desktop)