summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-21 18:29:23 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-21 20:50:10 +0100
commitb7489004a4aa7829f2cdf095133412dd1cdc7789 (patch)
tree7ce7096e48e3ea017ee8f4f21885302d9ef6b0ee /gnu
parentea4a1e5d0b13b5c548804ac854e6eb30c5149ce4 (diff)
downloadpatches-b7489004a4aa7829f2cdf095133412dd1cdc7789.tar
patches-b7489004a4aa7829f2cdf095133412dd1cdc7789.tar.gz
gnu: emacs-emms: Add dependency on Mutagen.
* gnu/packages/emacs-xyz.scm (emacs-emms)[arguments]: In 'configure' phase, for "emms-tag-editor.el", replace "mid3v2" but not "mp3info". [inputs]: Add PYTHON-MUTAGEN.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8463a91b8c..2ffca732ba 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages music)
#:use-module (gnu packages version-control)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages w3m)
@@ -968,6 +969,7 @@ skip set strings, which are arguments to @code{skip-chars-forward} and
(alsa (assoc-ref inputs "alsa-utils"))
(mpg321 (assoc-ref inputs "mpg321"))
(mp3info (assoc-ref inputs "mp3info"))
+ (mutagen (assoc-ref inputs "mutagen"))
(opus (assoc-ref inputs "opus-tools")))
;; Specify the installation directory.
(substitute* "Makefile"
@@ -1011,8 +1013,9 @@ skip set strings, which are arguments to @code{skip-chars-forward} and
(("\"amixer\"")
(string-append "\"" alsa "/bin/amixer\"")))
(substitute* "emms-tag-editor.el"
- (("\"mp3info\"")
- (string-append "\"" mp3info "/bin/mp3info\"")))))))
+ (("\"mid3v2\"")
+ (string-append "\"" mutagen "/bin/mid3v2\"")))
+ #t))))
(add-before 'install 'pre-install
(lambda* (#:key outputs #:allow-other-keys)
;; The 'install' rule expects the target directories to exist.
@@ -1045,6 +1048,7 @@ skip set strings, which are arguments to @code{skip-chars-forward} and
("mpg321" ,mpg321)
("taglib" ,taglib)
("mp3info" ,mp3info)
+ ("mutagen" ,python-mutagen)
("opus-tools" ,opus-tools)))
(properties '((upstream-name . "emms")))
(synopsis "Emacs Multimedia System")