summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-26 00:51:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-28 01:19:28 +0200
commit3c3c3d1d92a6eca36cb79fb4edd4fd874ed6b842 (patch)
tree62a9916cbc036f63127793440ff2a4aed7ea4664 /gnu
parenta0a2c2f16ac8220b41af0d484d9e48f37a329fd0 (diff)
downloadpatches-3c3c3d1d92a6eca36cb79fb4edd4fd874ed6b842.tar
patches-3c3c3d1d92a6eca36cb79fb4edd4fd874ed6b842.tar.gz
gnu: emacs-async: Download using git.
The MELPA tarball hash changed. Prevent this problem in the future by downloading a git checkout. * gnu/packages/emacs.scm (emacs-async)[home-page]: Update to actual. [source]: Use GIT-FETCH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5150705963..8665356f5c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1179,16 +1179,18 @@ rather than the contents of files.")
(define-public emacs-async
(package
(name "emacs-async")
+ (home-page "https://github.com/jwiegley/emacs-async")
(version "1.9.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://stable.melpa.org/packages/async-"
- version ".tar"))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xvi50y96y2qh81qkhj8p6ar1xnfasg58qvlsvgvvmdf4g8srlij"))))
+ "1zsnb6dy8p6y68xgidv3dfxaga4biramfw8fq7wac0sc50vc98vq"))))
(build-system emacs-build-system)
- (home-page "https://elpa.gnu.org/packages/async.html")
(synopsis "Asynchronous processing in Emacs")
(description
"This package provides the ability to call asynchronous functions and