summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-28 15:23:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-10-07 09:10:46 +0200
commitb1006576d7f233cf04ae149e8d089fe51203e0e8 (patch)
tree0dfa7d1551aa4c9d41c350285e56422c5e5f560b /gnu
parentf1a045e266ef0ac5e478b4f0346d548d58d8eaeb (diff)
downloadpatches-b1006576d7f233cf04ae149e8d089fe51203e0e8.tar
patches-b1006576d7f233cf04ae149e8d089fe51203e0e8.tar.gz
gnu: Add r-htmlwidgets.
* gnu/packages/web.scm (r-htmlwidgets): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fb76015cea..4d526fce0c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2954,3 +2954,26 @@ directory.")
(description
"This package provides tools for HTML generation and output in R.")
(license l:expat)))
+
+(define-public r-htmlwidgets
+ (package
+ (name "r-htmlwidgets")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "htmlwidgets" version))
+ (sha256
+ (base32
+ "1d583kk7g29r4sq0y1scri7fs48z6q17c051nyjywcvnpy4lvi8j"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/ramnathv/htmlwidgets")
+ (synopsis "HTML Widgets for R")
+ (description
+ "HTML widgets is a framework for creating HTML widgets that render in
+various contexts including the R console, R Markdown documents, and Shiny web
+applications.")
+ (license l:expat)))