summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-15 08:26:17 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-16 09:42:45 +0100
commit0d549f60df0c51653eb9784a55d32d0d5efc7c90 (patch)
treeac6690107dab67e1413095f54d5ebbe2d66ca8e6 /gnu
parent304a53f67aa4970dec98586e74c45487b0cd68ae (diff)
downloadpatches-0d549f60df0c51653eb9784a55d32d0d5efc7c90.tar
patches-0d549f60df0c51653eb9784a55d32d0d5efc7c90.tar.gz
gnu: messaging: Add libsignal-protocol-c.
* gnu/packages/messaging.scm (libsignal-protocol-c): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c0db36585b..397b96c5b0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -125,6 +126,35 @@ keys, no previous conversation is compromised.")
(home-page "https://otr.cypherpunks.ca/")
(license (list license:lgpl2.1 license:gpl2))))
+(define-public libsignal-protocol-c
+ (package
+ (name "libsignal-protocol-c")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/WhisperSystems/"
+ "libsignal-protocol-c/archive/v" version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1klz9jvbnmfc3qy2x6qcswzw14a7kyzs51dlg18yllvir1f1kz0s"))))
+ (arguments
+ `(;; Required for proper linking and for tests to run.
+ #:configure-flags '("-DBUILD_SHARED_LIBS=on" "-DBUILD_TESTING=1")))
+ (build-system cmake-build-system)
+ (inputs `( ;; Required for tests:
+ ("check", check)
+ ("openssl", openssl)))
+ (native-inputs `(("pkg-config", pkg-config)))
+ (home-page "https://github.com/WhisperSystems/libsignal-protocol-c")
+ (synopsis "Implementation of a ratcheting forward secrecy protocol")
+ (description "libsignal-protocol-c is an implementation of a ratcheting
+forward secrecy protocol that works in synchronous and asynchronous
+messaging environments. It can be used with messaging software to provide
+end-to-end encryption.")
+ (license license:gpl3+)))
+
(define-public bitlbee
(package
(name "bitlbee")