summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-01 14:21:50 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-02 10:40:35 -0500
commit66b9c74eb9eb9ded0d06ac378d7902571e95d51b (patch)
tree34313c8be5e640e69183bb8d6921b20792938135 /gnu
parentc16a204a7a946a33f4e5eaa79126b9e9debd8dfd (diff)
downloadpatches-66b9c74eb9eb9ded0d06ac378d7902571e95d51b.tar
patches-66b9c74eb9eb9ded0d06ac378d7902571e95d51b.tar.gz
gnu: Add List-AllUtils.
* gnu/packages/perl.scm (perl-list-allutils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e3e18b10b3..78f17f0509 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1983,6 +1983,30 @@ either uses the first module it finds or throws an error.")
versa.")
(license (package-license perl))))
+(define-public perl-list-allutils
+ (package
+ (name "perl-list-allutils")
+ (version "0.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+ "List-AllUtils-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qmfpmly0pghc94k6ifnd1vwzlv8nks27qkqs6h4p7vcricn7zjc"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-warnings" ,perl-test-warnings)))
+ (propagated-inputs
+ `(("perl-list-moreutils" ,perl-list-moreutils)
+ ("perl-scalar-list-utils" ,perl-scalar-list-utils)))
+ (home-page "http://search.cpan.org/dist/List-AllUtils")
+ (synopsis "Combination of List::Util and List::MoreUtils")
+ (description "This module exports all of the functions that either
+List::Util or List::MoreUtils defines, with preference to List::Util.")
+ (license (package-license perl))))
+
(define-public perl-list-moreutils
(package
(name "perl-list-moreutils")