summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 14:49:06 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:04 -0500
commit419dd41152dc84e57fbab4e488cfd579f7cd8961 (patch)
tree91fa085ef49b06b1aae9f869bb3da8b0317706c5 /gnu
parent41778634e2db3cade202f077c92e380e8249dc88 (diff)
downloadpatches-419dd41152dc84e57fbab4e488cfd579f7cd8961.tar
patches-419dd41152dc84e57fbab4e488cfd579f7cd8961.tar.gz
gnu: Add Perl YAML.
* gnu/packages/perl.scm (perl-yaml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b49bf2f382..902192bb6f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4563,6 +4563,27 @@ it. With this module, you can add your own magic to any variable without
having to write a single line of XS.")
(license (package-license perl))))
+(define-public perl-yaml
+ (package
+ (name "perl-yaml")
+ (version "1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/I/IN/INGY/"
+ "YAML-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sswbkyisgny7ksw34n7zdaxrhsbbn7dgjb9gjybpzhcnml476kc"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-yaml" ,perl-test-yaml)))
+ (home-page "http://search.cpan.org/dist/YAML")
+ (synopsis "YAML for Perl")
+ (description "The YAML.pm module implements a YAML Loader and Dumper based
+on the YAML 1.0 specification.")
+ (license (package-license perl))))
+
(define-public perl-yaml-tiny
(package
(name "perl-yaml-tiny")