summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-07-21 18:07:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-07-23 23:33:18 +0300
commitfd900d68a519938e4a5064fcede5da81728d32b1 (patch)
tree04e50976b164d4e5f2968ce1debdf648838c48f9 /gnu
parent826adfdb37656a5191a617c9eb6c8e8f80de0df8 (diff)
downloadpatches-fd900d68a519938e4a5064fcede5da81728d32b1.tar
patches-fd900d68a519938e4a5064fcede5da81728d32b1.tar.gz
gnu: Add support for aarch64's compiled kernel.
* gnu/packages/linux.scm (linux-libre)[arguments]: Add to the regex to find and install the aarch64-linux kernel. * gnu/system.scm (system-linux-image-file-name): Add entry for aarch64.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/system.scm1
2 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 94314d3f09..c116716e6e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -340,7 +340,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(kmod (assoc-ref (or native-inputs inputs) "kmod")))
;; Install kernel image, kernel configuration and link map.
(for-each (lambda (file) (install-file file out))
- (find-files "." "^(\\.config|bzImage|zImage|vmlinuz|System\\.map)$"))
+ (find-files "." "^(\\.config|bzImage|zImage|Image|vmlinuz|System\\.map)$"))
;; Install device tree files
(for-each (lambda (file) (install-file file dtbdir))
(find-files "." "\\.dtb$"))
diff --git a/gnu/system.scm b/gnu/system.scm
index 998bd68396..746c511187 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -392,6 +392,7 @@ from the initrd."
(cond
((string-prefix? "arm" (%current-system)) "zImage")
((string-prefix? "mips" (%current-system)) "vmlinuz")
+ ((string-prefix? "aarch64" (%current-system)) "Image")
(else "bzImage")))
(define (operating-system-kernel-file os)