summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-08 00:18:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-08 00:30:32 +0200
commit9567bd8dd9d092ac4bfdf9abfc35263e39146e26 (patch)
treed1547d2a09275f4cbb1d4494da3f11106c91e6e0 /gnu
parent9390300915a642c08a494aa67bf970c9a6ad5ff3 (diff)
downloadpatches-9567bd8dd9d092ac4bfdf9abfc35263e39146e26.tar
patches-9567bd8dd9d092ac4bfdf9abfc35263e39146e26.tar.gz
gnu: Add r-tidygraph.
* gnu/packages/cran.scm (r-tidygraph): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ac528468cb..19aa0522b1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15300,3 +15300,36 @@ stress majorization by Gansner et al. (2004)
<doi:10.1007/978-3-540-31843-9_25>. Some more specific algorithms allow to
emphasize hidden group structures in networks or focus on specific nodes.")
(license license:expat)))
+
+(define-public r-tidygraph
+ (package
+ (name "r-tidygraph")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidygraph" version))
+ (sha256
+ (base32
+ "1zpsarm74afbc7p5dlyb0whc09670qdcddw1ckb25cfc9hfh0hjn"))))
+ (properties `((upstream-name . "tidygraph")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-igraph" ,r-igraph)
+ ("r-magrittr" ,r-magrittr)
+ ("r-pillar" ,r-pillar)
+ ("r-r6" ,r-r6)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/thomasp85/tidygraph")
+ (synopsis "Tidy API for graph manipulation")
+ (description
+ "This package provides a graph implementation that can be thought of as
+two tidy data frames describing node and edge data respectively. It provides
+an approach to manipulate these two virtual data frames using the API defined
+in the @code{dplyr} package, and it also provides tidy interfaces to a lot of
+common graph algorithms.")
+ (license license:expat)))