summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-02 22:15:00 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-02 22:15:00 +0200
commit27477d2de087fd69227ccce49888cb8c2805f827 (patch)
treea8279c9c0a827cda98ce8d7778131c760c9cf876 /gnu
parent535dc6cf95c71ae1fdccc8e3bacbc282a11d5d78 (diff)
downloadpatches-27477d2de087fd69227ccce49888cb8c2805f827.tar
patches-27477d2de087fd69227ccce49888cb8c2805f827.tar.gz
gnu: Add icon-naming-utils.
* gnu/packages/gnome.scm (icon-naming-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4ac88ec342..c74761d218 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -24,6 +24,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libpng)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml))
@@ -84,6 +85,31 @@ and keep up to date translations of documentation.")
for settings shared by various components of the GNOME desktop.")
(license lgpl2.1+)))
+(define-public icon-naming-utils
+ (package
+ (name "icon-naming-utils")
+ (version "0.8.90")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://tango.freedesktop.org/releases/icon-naming-utils-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1mc3v28fdfqanx3lqx233vcr4glb4c2376k0kx2v91a4vxwqcdxi"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("perl" ,perl)
+ ("perl-xml-simple" ,perl-xml-simple)))
+ (home-page "http://tango.freedesktop.org/Standard_Icon_Naming_Specification")
+ (synopsis
+ "Utility to implement the Freedesktop Icon Naming Specification")
+ (description
+ "To help with the transition to the Freedesktop Icon Naming
+Specification, the icon naming utility maps the icon names used by the
+GNOME and KDE desktops to the icon names proposed in the specification.")
+ (license lgpl2.1+)))
+
(define-public libnotify
(package
(name "libnotify")