summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-07 15:43:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 23:32:43 +0100
commitdd5fc8b78ec5e1bcef35eae409c8faa9b88b6aa3 (patch)
tree1459d0e182ee2a66ab51e0f37d84b32025dc9414 /gnu
parente2b927993efc9254a941d035fb17f9ebaf330eac (diff)
downloadpatches-dd5fc8b78ec5e1bcef35eae409c8faa9b88b6aa3.tar
patches-dd5fc8b78ec5e1bcef35eae409c8faa9b88b6aa3.tar.gz
gnu: Add r-snpstats.
* gnu/packages/bioinformatics.scm (r-snpstats): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2200842164..a08f06ada7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9827,6 +9827,33 @@ of @dfn{quantitative trait loci} (QTL) archives, such as eQTL, mQTL, dsQTL,
and more.")
(license license:artistic2.0)))
+(define-public r-snpstats
+ (package
+ (name "r-snpstats")
+ (version "1.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "snpStats" version))
+ (sha256
+ (base32
+ "1x9qwynh2hwl24vq02naf4mchpch7xi2pkdrlgw896k28kx0lvir"))))
+ (properties `((upstream-name . "snpStats")))
+ (build-system r-build-system)
+ (inputs `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-matrix" ,r-matrix)
+ ("r-survival" ,r-survival)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (home-page "https://bioconductor.org/packages/snpStats")
+ (synopsis "Methods for SNP association studies")
+ (description
+ "This package provides classes and statistical methods for large
+@dfn{single-nucleotide polymorphism} (SNP) association studies. This extends
+the earlier snpMatrix package, allowing for uncertainty in genotypes.")
+ (license license:gpl3)))
+
(define-public r-qvalue
(package
(name "r-qvalue")