summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 19:28:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 19:28:03 +0100
commit5cfa4bff697fa0af43f6a7bbde7ec23c8a146e10 (patch)
tree6cc67907c81c0703f8e8902440937b8a88d243d0 /gnu
parentffe7029babb40481f50cf931b28e92c8f74dfe01 (diff)
downloadpatches-5cfa4bff697fa0af43f6a7bbde7ec23c8a146e10.tar
patches-5cfa4bff697fa0af43f6a7bbde7ec23c8a146e10.tar.gz
gnu: Add r-ebimage.
* gnu/packages/bioconductor.scm (r-ebimage): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6a7c98f625..f6ffacc04e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages graph)
#:use-module (gnu packages haskell)
+ #:use-module (gnu packages image)
#:use-module (gnu packages maths)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages statistics)
@@ -3586,3 +3587,42 @@ procedure. In addition, since the cells are evaluated individually, it can
easily be applied to bigger datasets, subsetting the expression matrix if
needed.")
(license license:gpl3)))
+
+(define-public r-ebimage
+ (package
+ (name "r-ebimage")
+ (version "4.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "EBImage" version))
+ (sha256
+ (base32
+ "18v2zr7xh0d0xbs7mxa2b6xjqlqiml0hji27gq1351xp5bf2pxvx"))))
+ (properties `((upstream-name . "EBImage")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-fftwtools" ,r-fftwtools)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-jpeg" ,r-jpeg)
+ ("r-locfit" ,r-locfit)
+ ("r-png" ,r-png)
+ ("r-rcurl" ,r-rcurl)
+ ("r-tiff" ,r-tiff)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr))) ; for vignettes
+ (home-page "https://github.com/aoles/EBImage")
+ (synopsis "Image processing and analysis toolbox for R")
+ (description
+ "EBImage provides general purpose functionality for image processing and
+analysis. In the context of (high-throughput) microscopy-based cellular
+assays, EBImage offers tools to segment cells and extract quantitative
+cellular descriptors. This allows the automation of such tasks using the R
+programming language and facilitates the use of other tools in the R
+environment for signal processing, statistical modeling, machine learning and
+visualization with image data.")
+ ;; Any version of the LGPL.
+ (license license:lgpl2.1+)))