summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 14:14:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 14:14:19 +0100
commit4774677228689df7c56efedc55c6ee06cd1e172d (patch)
tree3fa647a84219898670ce816f134d97f8b1bad14f /gnu
parent47131ebbc9fcabcbaa81d0aaf9fd499d65593a19 (diff)
downloadpatches-4774677228689df7c56efedc55c6ee06cd1e172d.tar
patches-4774677228689df7c56efedc55c6ee06cd1e172d.tar.gz
gnu: stepmania: Fix all instances of accessing application data.
This is a follow-up to commit 45aba232abe50b6642abfaa06030985c7febbe07. * gnu/packages/games.scm (stepmania)[arguments]: Rename phase ensure-gtk-module-can-be-found to ensure-application-files-can-be-found and fix remaining instances of application data access.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c7e08f8d98..5340ae5d5b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6182,12 +6182,21 @@ civilized than your own.")
"/lib/glib-2.0/include"))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'ensure-gtk-module-can-be-found
+ (add-after 'unpack 'ensure-application-files-can-be-found
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/arch/LoadingWindow/LoadingWindow_Gtk.cpp"
- (("RageFileManagerUtil::sDirOfExecutable \\+ \"/\" \\+ \"GtkModule.so\"")
- (string-append "\"" (assoc-ref outputs "out")
- "/share/stepmania/GtkModule.so\"")))
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "src/arch/LoadingWindow/LoadingWindow_Gtk.cpp"
+ (("RageFileManagerUtil::sDirOfExecutable \\+ \"/\" \\+ \"GtkModule.so\"")
+ (string-append "\"" out
+ "/share/stepmania/GtkModule.so\"")))
+ (substitute* "src/arch/ArchHooks/ArchHooks_Unix.cpp"
+ (("Root = sDirOfExecutable")
+ (string-append "Root = \"" out "/share/stepmania/\""))
+ (("sDirOfExecutable \\+ \"/(Packages|Songs)\"" _ dir)
+ (string-append "\"" out "/share/stepmania/" dir "\"")))
+ (substitute* "src/RageFileManager.cpp"
+ (("RageFileManagerUtil::sDirOfExecutable \\+ \"/\"")
+ (string-append "\"" out "/share/stepmania/\""))))
#t))
(add-after 'unpack 'fix-install-subdir
;; Installation would be done in "%out/stepmania-X.Y", but we