summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 03:46:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 04:07:43 +0100
commit146a4459db42e1fbda127e6f7a8db36253113b5e (patch)
treee5d816dfc59e6cd94d2e6ac16fca0a57362d861e /gnu
parenta01aea7d6614d31a1aca2d1acc127f3b2f8d37de (diff)
downloadpatches-146a4459db42e1fbda127e6f7a8db36253113b5e.tar
patches-146a4459db42e1fbda127e6f7a8db36253113b5e.tar.gz
gnu: no-more-secrets: Don't use unstable tarball.
* gnu/packages/games.scm (no-more-secrets)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ddf88f384b..c1a0ee699f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3914,13 +3914,13 @@ to the Space Age.")
(version "0.3.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/bartobri/no-more-secrets/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bartobri/no-more-secrets.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1kpx1rirc3i7fb4lymp0hx5rqr0s2ay4za261rw3bcy6d23l1kyg"))))
+ (base32 "1zfv4qabikf8w9winsr4brxrdvs3f0d7xvydksyx8bydadsm2v2h"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f