summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-24 22:55:32 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-24 22:55:32 +0200
commit0899144f797b5a660bee17427a7d07d70ba89bc4 (patch)
tree6cc0edf39e892b7354386bb8069b38222b0ef9ac /gnu
parent0c09a306e59e2feec9818335b0b4f3355c02f420 (diff)
downloadpatches-0899144f797b5a660bee17427a7d07d70ba89bc4.tar
patches-0899144f797b5a660bee17427a7d07d70ba89bc4.tar.gz
gnu: Add xmlsec.
* gnu/packages/xml.scm (xmlsec): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d30c40ce1a..8a4d2fbb5b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -20,8 +20,10 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gnutls)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages web)
@@ -387,3 +389,32 @@ that conforms to the API of the Document Object Model.")
stylesheet for the conversion you want and applies it using an external
XSL-T processor. It also performs any necessary post-processing.")
(license license:gpl2+)))
+
+(define-public xmlsec
+ (package
+ (name "xmlsec")
+ (version "1.2.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.aleksey.com/xmlsec/download/"
+ name "1-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01bkbv2y3x8d1sf4dcln1x3y2jyj391s3208d9a2ndhglly5j89j"))))
+ (build-system gnu-build-system)
+ (propagated-inputs ; according to xmlsec1.pc
+ `(("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt)
+ ("libltdl" ,libltdl)))
+ (home-page "http://www.libexpat.org/")
+ (synopsis "XML Security Library")
+ (description
+ "The XML Security Library is a C library based on Libxml2. It
+supports XML security standards such as XML Signature, XML Encryption,
+Canonical XML (part of Libxml2) and Exclusive Canonical XML (part of
+Libxml2).")
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))