summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-01-29 10:00:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-09 09:00:02 +0100
commitc54a89811f3290f2489d67867ab6f68cf3059e4e (patch)
treece5bc742116fb712a2a99112ce9d1755efd73db7 /gnu
parent2cd85cf9e18cf433caf01405aad523c3f32720f1 (diff)
downloadpatches-c54a89811f3290f2489d67867ab6f68cf3059e4e.tar
patches-c54a89811f3290f2489d67867ab6f68cf3059e4e.tar.gz
gnu: Add JACK2.
* gnu/packages/audio.scm (jack-2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index daf7feb1aa..d5b862f515 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -22,9 +22,16 @@
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system waf)
#:use-module (gnu packages)
#:use-module (gnu packages databases)
- #:use-module (gnu packages linux))
+ #:use-module (gnu packages glib) ;dbus
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio) ;libsndfile, libsamplerate
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages xml))
(define-public jack-1
(package
@@ -55,3 +62,33 @@ synchronous execution of all clients, and low latency operation.")
;; Most files are licensed under the GPL. However, the libjack/ tree is
;; licensed under the LGPL in order to allow for proprietary usage.
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public jack-2
+ (package (inherit jack-1)
+ (name "jack")
+ (version "1.9.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/jackaudio/jack2/archive/v"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03b0iiyk3ng3vh5s8gaqwn565vik7910p56mlbk512bw3dhbdwc8"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:configure-flags '("--dbus"
+ "--alsa")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("dbus" ,dbus)
+ ("expat" ,expat)
+ ("libsamplerate" ,libsamplerate)
+ ("opus" ,opus)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ ;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
+ (license (list license:gpl2+ license:lgpl2.1+))))