summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 18:25:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 18:38:32 +0200
commit35aaf4b1bd146f9f0277b9484e05470ec7424738 (patch)
tree2e9bca743722659d153756c044e7afb2f773b0d3 /gnu
parent237edb6d1f3c9034417983227fe7fdca4a5cee2c (diff)
downloadpatches-35aaf4b1bd146f9f0277b9484e05470ec7424738.tar
patches-35aaf4b1bd146f9f0277b9484e05470ec7424738.tar.gz
gnu: Add perl-type-tiny-xs.
* gnu/packages/perl.scm (perl-type-tiny-xs): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 47a1399270..e1e15bd076 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8715,6 +8715,27 @@ distributed as part of @code{Type::Tiny} but has since been spun off), and can
be used with Moose, Mouse and Moo (or none of the above).")
(license (package-license perl))))
+(define-public perl-type-tiny-xs
+ (package
+ (name "perl-type-tiny-xs")
+ (version "0.012")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TOBYINK/Type-Tiny-XS-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05nbr898cvjjh1wsy55l84zasx65gijdxc6dnn558ihns8zx6gm9"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Type-Tiny-XS/")
+ (synopsis "Provides an XS boost for some of Type::Tiny's built-in type constraints")
+ (description "This module is optionally used by @code{Type::Tiny} to
+provide faster, C-based implementations of some type constraints. This
+package has only core dependencies, and does not depend on @code{Type::Tiny},
+so other data validation frameworks might also consider using it.")
+ (license perl-license)))
+
(define-public perl-types-serialiser
(package
(name "perl-types-serialiser")