summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-25 08:53:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-25 10:49:38 +0200
commit2a013d0f093fe45b26885d328ca71a04590e0f91 (patch)
tree64009d82c4d4c8f5b95738695a75be597e8b7601 /gnu
parentfc4083c54f603f9a4d593661641e88cfae0c35d1 (diff)
downloadpatches-2a013d0f093fe45b26885d328ca71a04590e0f91.tar
patches-2a013d0f093fe45b26885d328ca71a04590e0f91.tar.gz
gnu: Add perl-carp-always.
* gnu/packages/perl.scm (perl-carp-always): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d92cc18bd1..3b58942d60 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -649,6 +649,28 @@ is captured while being passed through to the original file handles.")
to test the installed perl for compatibility with his modules.")
(license (package-license perl))))
+(define-public perl-carp-always
+ (package
+ (name "perl-carp-always")
+ (version "0.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/F/FE/FERREIRA/Carp-Always-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0i2rifkr7ybfcdsqana52487z7vxp2l5qdra0f6ik0ddhn6rzii1"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-base" ,perl-test-base)))
+ (home-page "http://search.cpan.org/dist/Carp-Always")
+ (synopsis "Warns and dies noisily with stack backtraces/")
+ (description "This module is meant as a debugging aid. It can be used to
+make a script complain loudly with stack backtraces when @code{warn()}-ing or
+@code{die()}ing.")
+ (license (package-license perl))))
+
(define-public perl-carp-assert
(package
(name "perl-carp-assert")