summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-05 11:11:38 -0500
committerLeo Famulari <leo@famulari.name>2017-01-06 17:16:03 -0500
commite483139141c170131cca6589dc7942d7186329da (patch)
tree7b2766931bcdb1857f18af530b21a1975c47355f /gnu
parent11b6687609f24e3f238314c4b40a54341f96ab3c (diff)
downloadpatches-e483139141c170131cca6589dc7942d7186329da.tar
patches-e483139141c170131cca6589dc7942d7186329da.tar.gz
gnu: glibc/linux: Use /bin/sh instead of /bin/bash as the default shell.
* gnu/packages/base.scm (glibc/linux)[arguments]: Use /bin/sh for scripts that lack a shebang.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 3457c79bbc..4898b181e9 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -629,7 +629,7 @@ store.")
(substitute* (find-files "." "^paths\\.h$")
(("#define[[:blank:]]+_PATH_BSHELL[[:blank:]].*$")
(string-append "#define _PATH_BSHELL \""
- bash "/bin/bash\"\n")))
+ bash "/bin/sh\"\n")))
;; Nscd uses __DATE__ and __TIME__ to create a string to
;; make sure the client and server come from the same