summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-09 11:26:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-09 13:01:15 +0100
commit83b9d121a78e6bb4e3d57474d3e01d0a3c4dd5e9 (patch)
treee9dd9525419dd1c7bcb26d776481471a6dc567b3 /gnu
parent145a5310cd8c5711ddb96637986709abe49955c6 (diff)
downloadpatches-83b9d121a78e6bb4e3d57474d3e01d0a3c4dd5e9.tar
patches-83b9d121a78e6bb4e3d57474d3e01d0a3c4dd5e9.tar.gz
gnu: bedtools-2.18: Fix build.
* gnu/packages/bioinformatics.scm (bedtools-2.18)[arguments]: Restore custom install phase. Reported by Mark H Weaver <mhw@netris.org>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fedc8aec4c..171b13d0d5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -466,7 +466,19 @@ BED, GFF/GTF, VCF.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "05vrnr8yp7swfagshzpgqmzk1blnwnq8pq5pckzi1m26w98d63vf"))))))
+ "05vrnr8yp7swfagshzpgqmzk1blnwnq8pq5pckzi1m26w98d63vf"))))
+ (arguments
+ '(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+ (for-each (lambda (file)
+ (install-file file bin))
+ (find-files "bin" ".*")))
+ #t)))))))
(define-public ribotaper
(package