summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-30 08:50:39 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-30 08:50:39 +0100
commit47038b76b23ef69f3ed78ded2a03ef0c49408286 (patch)
treebb8c57cf982cef33dc1af4a2982d6d7b01bd2769 /gnu
parent979bc0f49b1de09239b2bd70a079d38ca69cf516 (diff)
downloadpatches-47038b76b23ef69f3ed78ded2a03ef0c49408286.tar
patches-47038b76b23ef69f3ed78ded2a03ef0c49408286.tar.gz
gnu: xorg: Make xgamma compile.
* gnu/packages/xorg.scm (libxxf86vm): Propagate inputs libxext and xf86vidmodeproto.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm54
1 files changed, 28 insertions, 26 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 9a4394bf81..dfd5500198 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1767,32 +1767,6 @@ and Matrox.")
(license license:x11)))
-(define-public libxxf86vm
- (package
- (name "libxxf86vm")
- (version "1.1.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/X11R7.7/src/everything/libXxf86vm-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "117w92xz39rcqcahspi48nc04cc9110x1dycpf3vbcb6p0pifr55"))))
- (build-system gnu-build-system)
- (inputs
- `(("libx11" ,libx11)
- ("libxext" ,libxext)
- ("pkg-config" ,pkg-config)
- ("xf86vidmodeproto" ,xf86vidmodeproto)))
- (home-page "http://www.x.org/wiki/")
- (synopsis "xorg implementation of the X Window System")
- (description "X.org provides an implementation of the X Window System")
- (license license:x11)))
-
-
(define-public luit
(package
(name "luit")
@@ -4635,6 +4609,34 @@ emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
+(define-public libxxf86vm
+ (package
+ (name "libxxf86vm")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/X11R7.7/src/everything/libXxf86vm-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "117w92xz39rcqcahspi48nc04cc9110x1dycpf3vbcb6p0pifr55"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("libxext" ,libxext)
+ ("xf86vidmodeproto" ,xf86vidmodeproto)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.x.org/wiki/")
+ (synopsis "xorg implementation of the X Window System")
+ (description "X.org provides an implementation of the X Window System")
+ (license license:x11)))
+
+
(define-public xorg-server
(package
(name "xorg-server")