summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-04-28 21:12:55 +0200
committerAndreas Enge <andreas@enge.fr>2013-04-28 21:12:55 +0200
commit1f7c6a1f53d0a752af70de123f2ce9d138e0db0a (patch)
treee7a880d2f56a1641c039080aecb2352ebbbcfa4a /gnu
parentcecb712cce32467b8dd4eb3ececc522c209c93a2 (diff)
downloadpatches-1f7c6a1f53d0a752af70de123f2ce9d138e0db0a.tar
patches-1f7c6a1f53d0a752af70de123f2ce9d138e0db0a.tar.gz
gnu: Add gs-fonts.
* gnu/packages/ghostscript.scm (gs-fonts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ghostscript.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 2c58bca0bd..1f4aa2f77a 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -171,3 +171,45 @@ It consists of a PostScript interpreter layer, and a graphics
library.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/ghostscript/")))
+
+(define-public gs-fonts
+ (package
+ (name "gs-fonts")
+ (version "8.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gs-fonts/gs-fonts/"
+ version
+ "%20%28base%2035%2C%20GPL%29/ghostscript-fonts-std-"
+ version
+ ".tar.gz"))
+ (sha256 (base32
+ "00f4l10xd826kak51wsmaz69szzm2wp8a41jasr4jblz25bg7dhf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; nothing to check, just files to copy
+ #:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1)) ; for alist-delete
+ #:phases
+ (alist-delete
+ 'configure
+ (alist-delete
+ 'build
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/share/fonts/type1/ghostscript")))
+ (mkdir-p dir)
+ (for-each
+ (lambda (file)
+ (copy-file file (string-append dir "/" file)))
+ (find-files "." "pfb|afm"))))
+ %standard-phases)))))
+ (synopsis "free replacements for the PostScript fonts")
+ (description
+ "gs-fonts provides fonts and font metrics customarily distributed with
+Ghostscript. It currently includes the 35 standard PostScript fonts.")
+ (license license:gpl2)
+ (home-page "http://sourceforge.net/projects/gs-fonts/")))