summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 11:24:52 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:03 -0500
commita1c9547f2583d97879c01795be57c7debeaefa8e (patch)
treee9307d6542b8234189f2df920ebd9e43dd13f157 /gnu
parentbe73447995d6a14ef6b6c3e1011e7a3020d72d96 (diff)
downloadpatches-a1c9547f2583d97879c01795be57c7debeaefa8e.tar
patches-a1c9547f2583d97879c01795be57c7debeaefa8e.tar.gz
gnu: Add Cache-FastMmap.
* gnu/packages/perl.scm (perl-cache-fastmmap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a4df03196b..37094e28d7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -281,6 +281,27 @@ runs of an application or invocations of a CGI-style script or simply as an
easy to use abstraction of the filesystem or shared memory.")
(license (package-license perl))))
+(define-public perl-cache-fastmmap
+ (package
+ (name "perl-cache-fastmmap")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RO/ROBM/"
+ "Cache-FastMmap-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h3ckr04cdn6dvl40m4m97vl5ybf30v1lwhw3jvkr92kpksvq4hd"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Cache-FastMmap")
+ (synopsis "Shared memory interprocess cache via mmap")
+ (description "A shared memory cache through an mmap'ed file. It's core is
+written in C for performance. It uses fcntl locking to ensure multiple
+processes can safely access the cache at the same time. It uses a basic LRU
+algorithm to keep the most used entries in the cache.")
+ (license (package-license perl))))
+
(define-public perl-capture-tiny
(package
(name "perl-capture-tiny")