summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-04 20:20:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:01 +0200
commit6859cac498dff10f20c50fb2582974dcfa48c724 (patch)
tree4aa22d3bd7e42f557acd6c8c56bddb79720d95e8 /gnu
parent264c773e069021c3e97748c39b051a8a8dec1243 (diff)
downloadpatches-6859cac498dff10f20c50fb2582974dcfa48c724.tar
patches-6859cac498dff10f20c50fb2582974dcfa48c724.tar.gz
gnu: emacs-company-quickhelp: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-company-quickhelp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 249c38b415..c0f34fb994 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2942,14 +2942,13 @@ for the current function or variable in the minibuffer.")
(version "2.3.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/expez/company-quickhelp/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/expez/company-quickhelp.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0xrn2z1dgk5gmkmp2jkn9g83ckk39lqp5pyyv8rl7f6gqvib3qh0"))))
+ (base32 "08ccsfvwdpzpj0gai3xrdb2bv1nl6myjkxsc5774pbvlq9nkfdvr"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-pos-tip" ,emacs-pos-tip)