summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-11-20 20:40:49 +0000
committerChristopher Baines <mail@cbaines.net>2017-11-21 08:41:26 +0000
commita0fe7c06452ad89d15e38ba2b698228f4fe3a76d (patch)
treef7dd6afcdec90dd143838129f7abe579ffa9ddf0 /gnu
parent0056f4cc57f4e3111cd707b62bbbc8b615add135 (diff)
downloadpatches-a0fe7c06452ad89d15e38ba2b698228f4fe3a76d.tar
patches-a0fe7c06452ad89d15e38ba2b698228f4fe3a76d.tar.gz
gnu: Patch path to locale in gnome-desktop.
* gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-path phase to get libgnome-desktop to use the full path to the locale binary.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 25e0e8fe31..86ec22d336 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -454,6 +454,16 @@ commonly used macros.")
(base32
"0pkq5l1llw8gkjhfq6y58iyj6wac8dh1mc3rzjzn6nd7lrkdx8cg"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc")))
+ (substitute* "libgnome-desktop/gnome-languages.c"
+ (("\"locale\"")
+ (string-append "\"" libc "/bin/locale\"")))
+ #t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("itstool" ,itstool)