summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:27:51 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:16 +0100
commit8bfe007c9caf464ed5a646b4a3203d8e959ff6f9 (patch)
tree993a6fcc3c6660f9033c3d15518c47c3513bf9e0 /gnu
parenta69a59359587f7797a717a0431d062ca4a454da2 (diff)
downloadpatches-8bfe007c9caf464ed5a646b4a3203d8e959ff6f9.tar
patches-8bfe007c9caf464ed5a646b4a3203d8e959ff6f9.tar.gz
gnu: Add R.methodsS3.
* gnu/packages/statistics.scm (r-r-methodss3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index afa9f12668..ffedaca8b1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1737,3 +1737,27 @@ The 'DataTables' library has been included in this R package.")
flexible than the orphaned \"base64\" package.")
(license license:gpl2+)))
+(define-public r-r-methodss3
+ (package
+ (name "r-r-methodss3")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "R.methodsS3" version))
+ (sha256
+ (base32
+ "1dg4bbrwr8jcsqisjrrwxs942mrjq72zw8yvl2br4djdm0md8zz5"))))
+ (properties `((upstream-name . "R.methodsS3")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/R.methodsS3")
+ (synopsis "S3 methods simplified")
+ (description
+ "This package provides methods that simplify the setup of S3 generic
+functions and S3 methods. Major effort has been made in making definition of
+methods as simple as possible with a minimum of maintenance for package
+developers. For example, generic functions are created automatically, if
+missing, and naming conflict are automatically solved, if possible. The
+method @code{setMethodS3()} is a good start for those who in the future may
+want to migrate to S4.")
+ (license license:lgpl2.1+)))
+