summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-11 23:17:07 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-12 13:47:50 +0100
commit30e9cbb44ed70ef6154267e53ba0fcb77bb94ade (patch)
treec7afaf40143c2f783110d9eb4af3845ff8837c3b /gnu
parenta86177d61cdc1acaa47132615c67eec3e43b9dca (diff)
downloadpatches-30e9cbb44ed70ef6154267e53ba0fcb77bb94ade.tar
patches-30e9cbb44ed70ef6154267e53ba0fcb77bb94ade.tar.gz
gnu: gnupg: Patch out /bin/sh in generated file.
* gnu/packages/gnupg.scm (gnupg): Modify configure phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index baf322721d..c198f90865 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -155,6 +155,16 @@ specifications are building blocks of S/MIME and TLS.")
("libgpg-error" ,libgpg-error)
("zlib" ,guix:zlib)
("readline" ,readline)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ (substitute* "tests/openpgp/Makefile.in"
+ (("/bin/sh") (which "bash")))
+ (apply configure args)))
+ %standard-phases)))
(home-page "http://gnupg.org/")
(synopsis
"GNU Privacy Guard (GnuPG), GNU Project's implementation of the OpenPGP standard")