summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-12 15:15:18 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-12 15:15:18 +0100
commit01e11826bc01691b4c142dbd30dfb2b94418dbda (patch)
tree292d6d5b659d9101ed725e1fb03880edd10ec93c /gnu
parent30e9cbb44ed70ef6154267e53ba0fcb77bb94ade (diff)
downloadpatches-01e11826bc01691b4c142dbd30dfb2b94418dbda.tar
patches-01e11826bc01691b4c142dbd30dfb2b94418dbda.tar.gz
gnu: gnupg: Add optional inputs curl and openldap.
* gnu/packages/gnupg.scm (gnupg): Add inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c198f90865..046d4c2d76 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -19,6 +19,8 @@
(define-module (gnu packages gnupg)
#:use-module (guix licenses)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages pth)
#:use-module (gnu packages python)
@@ -142,17 +144,16 @@ specifications are building blocks of S/MIME and TLS.")
"08n636sfffs5qvg9ppiprvsh00q0dmdw425psg3m3nssja53m8pg"))))
(build-system gnu-build-system)
(inputs
- `(;; TODO: Add missing optional deps.
- ;; ("curl" ,curl)
- ;; ("libusb" ,libusb)
- ;; ("openldap" ,openldap)
-
+ `(;; TODO: Add missing optional dep libusb.
+;; ("libusb" ,libusb)
("bzip2" ,guix:bzip2)
+ ("curl" ,curl)
("libassuan" ,libassuan)
("libgcrypt" ,libgcrypt)
+ ("libgpg-error" ,libgpg-error)
("libksba" ,libksba)
("pth" ,pth)
- ("libgpg-error" ,libgpg-error)
+ ("openldap" ,openldap)
("zlib" ,guix:zlib)
("readline" ,readline)))
(arguments