summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-27 14:52:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-27 15:07:21 +0200
commit522f19956207cee6ccd603d152f5df296d445dc3 (patch)
tree4a7488b394a76cab250bcc9a29b293aeaf9eced6 /gnu
parent997856746019ff4f6e0dcc66cd1ac647f4e5a4aa (diff)
downloadpatches-522f19956207cee6ccd603d152f5df296d445dc3.tar
patches-522f19956207cee6ccd603d152f5df296d445dc3.tar.gz
gnu: perl-xml-atom: Update to 0.42.
* gnu/packages/xml.scm (perl-xml-atom): Update to 0.42. [arguments]: Add 'set-perl-search-path' phase. [native-inputs]: Add PERL-HTML-TAGSET and PERL-MODULE-BUILD-TINY.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 44fa48af8c..dd229ba73b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -227,18 +227,29 @@ the @code{Graph} class and write it out in a specific file format.")
(define-public perl-xml-atom
(package
(name "perl-xml-atom")
- (version "0.41")
+ (version "0.42")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/"
"XML-Atom-" version ".tar.gz"))
(sha256
(base32
- "17lnkb9ymrhk2z642bhj5i2bv3q1da3kpp2lvsl0yhqshk3wdjj8"))))
+ "1wa8kfy1w4mg7kzxim4whyprkn48a2il6fap0b947zywknw4c6y6"))))
(build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-perl-search-path
+ (lambda _
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(native-inputs
`(("perl-datetime" ,perl-datetime)
;; TODO package: perl-datetime-format-atom
+ ("perl-html-tagset" ,perl-html-tagset)
+ ("perl-module-build-tiny" ,perl-module-build-tiny)
("perl-module-install" ,perl-module-install)
("perl-xml-xpath" ,perl-xml-xpath)))
(inputs